PAT 1007 Maximum Subsequence Sum [在线处理]

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

------------------------------------这是题目和解题的分割线------------------------------------

用的陈越老师的在线处理法,复杂度只用O(N)。

不过有个问题很奇怪,printf("%d %d %d",maxSequence(a,n),a[thisI],a[thisJ]); 这样写七个测试点有六个会答案错误。而且不是编译错误,是答案错误= = 

而改成 int x = maxSequence(a,n); printf("%d %d %d",x,a[thisI],a[thisJ]); 就完全正确了。

所以是有返回值的函数得先赋值再输出的原因吗???

#include<cstdio>

int thisI,thisJ,tmp;

//在线处理,复杂度O(N) 
int maxSequence(int a[],int n)
{
	int i,thisSum = 0,maxSum = 0;
	//必须初始化,thisI和thisJ是以防出现全为负数需要输出第一个和最后一个数值
	//tmp = 0:如果数组的第一个值不为负数,则会直接进入第一个条件判断,让thisI=tmp 
	thisI = 0,thisJ = n-1,tmp = 0;
	for(i=0;i<n;i++)
	{
		thisSum += a[i]; //当前数字的总和 
		if(thisSum>=maxSum) //大于等于最大数值 
		{
			//如果相等且maxSum大于零,即出现第2+次相同的最大值,依题意取顺序在前的,所以continue 
			if(thisSum==maxSum&&maxSum!=0) continue;
			maxSum = thisSum; //更新最大值 
			thisI = tmp; //2.如果从记录下的坐标开始的序列和大于最大和,更新起始坐标 
			thisJ = i; //更新末端坐标 
		}
		else if(thisSum<0)
		{
			tmp = i+1;//1.如果当前和为负数,记录第一个使和>=0的坐标 
			thisSum = 0; //当前和重新计算 
		}
	}
	return maxSum;
}

int main()
{
	int n,a[10005],i;
	scanf("%d",&n);
	for(i=0;i<n;i++)
		scanf("%d",&a[i]);
	//不能像下面这样直接输出,要先赋值给x,不然会收获百分之九十的答案错误 
	//printf("%d %d %d",maxSequence(a,n),a[thisI],a[thisJ]);
	int x = maxSequence(a,n);
	printf("%d %d %d",x,a[thisI],a[thisJ]); //输出值不是下标 
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值