1001 A+B Format (20分)

1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​ ≤a,b≤10​6​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

思路
首先看范围,用int足够。
然后简单相加,没什么可说的。
最后将数字转换为字符数组,依次输出字符,到一定位置输出“,”

核心代码

	int r=a+b;//整数型的结果
	string res;//string变量
	stringstream ss;//string流
	ss<<r;
	ss>>res;
	int len=res.length();
	char num[len];
	res.copy(num,len);//将res的len长度部分赋值给num字符数组

代码

#include<stdio.h>
#include<iostream>
#include<sstream>
#include<string>
using namespace std;
int main(){
	int a,b;
	cin>>a>>b;
	int r=a+b;
	string res;
	stringstream ss;
	ss<<r;
	ss>>res;
	int len=res.length();
	char num[len];
	res.copy(num,len);
	int st=0;
	int flag=0;
	if(r<0){
		st=1;
		flag=2;
		cout<<"-";
	}
	int count=0;
	for(int i=st;i<len;i++){
		cout<<num[i];
		count=count+1;
		if((len-count+flag)%3==0&&i!=len-1){
			cout<<",";
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值