HDU1045:Fire Net

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input
4 .X… … XX… … 2 XX .X 3 .X. X.X .X. 3 … .XX .XX 4 … … … … 0

Sample Output
5 1 5 2 4

题目大意:就是要安装堡垒,堡垒会发出子弹,子弹打墙壁是不会打穿的,有点像八皇后的问题,问最多可以放几个堡垒。
解题思路:1.因为是专题里面,一开始就知道用dfs,而且最大n=4,运用深度优先搜索,找出最多的情况。
2.然后在别人的代码里面发现可以用二分图匹配,立马就学习到了,把图按行分成几个部分,按列也分成几个部分,比如按列分可以分成
1 0 5 6
1 3 5 6
0 0 5 6
2 4 5 6 (其中相同的数字代表一个块)为题目样例的分法,列也类似。
然后就是求二分图的最大匹配了。

dfs的代码

#include<bits/stdc++.h>
using namespace std;
int cnt;
int n;
int l;
int to[4][2]={0,1,0,-1,1,0,-1,0};
struct nobe{
int x,y;
}a[20];
int mp[4][4];
int judge(int x,int y)
{
    if(x<0||x>=n||y<0||y>=n)
        return -1;
    return mp[x][y];
}
bool check(int k)
{
    int flag=0;
    int x,y;
    int dx,dy;
    x=a[k].x;
    y=a[k].y;
    for(int i=0;i<4;i++)
    {
        if(flag)
            break;
        dx=x+to[i][0];
        dy=y+to[i][1];
        while(1)
        {
            int t=judge(dx,dy);
            if(t==1)
            {
                flag=1;
                break;
            }
            if(t==-1)
                break;
            dx+=to[i][0];
            dy+=to[i][1];
        }
    }
    return flag;
}
void dfs(int k,int num)
{
    if(num>cnt)
        cnt=num;
    int i,j;
    if(k==l)
        return;
    i=a[k].x;
    j=a[k].y;
    dfs(k+1,num);
    if(!check(k))
    {
        mp[i][j]=1;
        dfs(k+1,num+1);
        mp[i][j]=0;
    }

}
int main()
{

    while(cin>>n)
    {
        if(n==0)
            break;
        char x;
        l=0;
        memset(mp,0,sizeof(mp));
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
        {
            cin>>x;
            if(x=='.')
               {
                mp[i][j]=0;
                a[l].x=i;
                a[l].y=j;
                l++;
               }
            else
                mp[i][j]=-1;
        }
        cnt=0;
        dfs(0,0);
        cout<<cnt<<endl;
    }

}

二分匹配的代码:

#include<bits/stdc++.h>
using namespace std;
int n;
int r;
int c;
int ans;
char mp[5][5];
int col[5][5];
int row[5][5];
int user[20];
int nxt[20];
int path[20][20];
bool Find(int x)
{
    for(int i=1;i<=r;i++)
    {
        if(path[x][i]&&!user[i])
        {
            user[i]=1;
            if(nxt[i]==0||Find(nxt[i]))
                {
                    nxt[i]=x;
                    return true;
                }
        }
    }
    return false;
}
void maxmatch()
{
    for(int i=1;i<=c;i++)
    {
        memset(user,0,sizeof(user));
        if(Find(i))
            ans++;
    }
}
int main()
{
    while(cin>>n&&n)
    {
        ans=0;
        memset(row,0,sizeof(col));
        memset(col,0,sizeof(row));
        memset(nxt,0,sizeof(nxt));
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
                cin>>mp[i][j];
        }
        r=1;
        c=1;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                int x=i;
                if(mp[x][j]=='.'&&row[x][j]==0)
                {
                    while(mp[x][j]=='.'&&row[x][j]==0)
                    {
                        row[x][j]=r;
                        x++;
                    }
                    r++;
                }
            }
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                int y=j;
                if(mp[i][j]=='.'&&col[i][j]==0)
                {
                    while(mp[i][y]=='.'&&col[i][y]==0)
                    {
                        col[i][y]=c;
                        y++;
                    }
                    c++;
                }
            }
        memset(path,0,sizeof(path));
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            path[row[i][j]][col[i][j]]=1;
        maxmatch();
        cout<<ans<<endl;
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值