HDU-2586 LCA 模板 倍增法

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22964    Accepted Submission(s): 9075


 

Problem Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

 

 

Input

First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

 

 

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

 

 

Sample Input

 

2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1

 

 

Sample Output

 

10 25 100 100

 

求两点树上最小距离:即根到两点距离-两倍到其最近公共祖先距离

 

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=80005;
const int maxm=1000005;
const int inf=0x3f3f3f3f;
typedef long long ll;
int n,m,dep[maxn],fa[maxn][25],now;
ll dist[maxn],head[maxn];
int to[maxm],nex[maxm],val[maxm];


void add(int u,int v,int w){
    val[now]=w,to[now]=v;
    nex[now]=head[u],head[u]=now++;
}
void init(){
    mem(head,-1); mem(dep,0);
    now=0; mem(dist,0);
}
void dfs(int now,int f,int deps){
    dep[now]=deps;
    fa[now][0]=f;
    for(int i=head[now];~i;i=nex[i]){
        int u=to[i],w=val[i];
        if(u==f) continue;
        if(!dist[u]){
            dist[u]=dist[now]+w;
            dfs(u,now,deps+1);
        }
    }
}
void solve(){
    for(int j=1;(1<<j)<=n;j++)
        for(int i=1;i<=n;i++)
            fa[i][j]=fa[fa[i][j-1]][j-1];
}
int LCA(int x,int y){
    if(dep[x]<dep[y]) swap(x,y);
    for(int i=20;i>=0;i--)
        if(dep[fa[x][i]]>=dep[y])
            x=fa[x][i];
    if(x==y) return x;
    for(int i=20;i>=0;i--)
        if(fa[x][i]!=fa[y][i])
            x=fa[x][i],y=fa[y][i];
    return fa[x][0];
}
int main(){
    int t,x,y,z;
    cin>>t;
    while(t--){
        scanf("%d%d",&n,&m);
        init();
        for(int i=1;i<n;i++){
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);
            add(y,x,z);
        }
        dfs(1,-1,1);
        solve();
        while(m--){
            scanf("%d%d",&x,&y);
            printf("%lld\n",dist[x]+dist[y]-2*dist[LCA(x,y)]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值