【HDU - 2586】How far away ? (树链剖分实现的LCA)

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this “How far is it if I want to go from house A to house B”? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path(“simple” means you can’t visit a place twice) between every two houses. Yout task is to answer all these curious people.
Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000)k(0<k<=40000).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
Sample Input
2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1
Sample Output
10
25
100
100
代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<set>
#define ll long long
#define maxx 40005
#define INF 0x7f7f7f7f
using namespace std;
int n,m;
int head[maxx],to[maxx<<1],_next[maxx<<1],w[maxx<<1];
int edge;
inline void addEdge(int x,int y,int z)
{
    to[++edge]=y,_next[edge]=head[x],w[edge]=z,head[x]=edge;
    to[++edge]=x,_next[edge]=head[y],w[edge]=z,head[y]=edge;
}
int dis[maxx];
int deep[maxx];
int sz[maxx];
int son[maxx];
int fa[maxx];
void dfs1(int u,int f)
{
    sz[u]=1;
    int maxson=-1;
    for(int i=head[u];i;i=_next[i])
    {
        int v=to[i];
        if(v==f)continue;
        fa[v]=u;
        deep[v]=deep[u]+1;
        dis[v]=dis[u]+w[i];

        dfs1(v,u);
        sz[u]+=sz[v];

        if(maxson<sz[v])
        {
            maxson=sz[v];
            son[u]=v;
        }
    }
}
int top[maxx];
void dfs(int u,int f,int t)
{
    top[u]=t;
    if(son[u])
    {
        dfs(son[u],u,t);
        for(int i=head[u];i;i=_next[i])
        {
            int v=to[i];
            if(v==son[u]||v==f)continue;
            dfs(v,u,v);
        }
    }
}
int lca(int x,int y)
{
    while(top[x]!=top[y])
    {
        if(deep[top[x]]>deep[top[y]])x=fa[top[x]];
        else y=fa[top[y]];
    }
    return deep[x]>deep[y]?y:x;
}
void init()
{
    memset(head,0,sizeof(head));
    memset(son,0,sizeof(son));
    edge=0;
}
int main()
{
    int t;cin>>t;
    int x,y,z;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            addEdge(x,y,z);
        }
        dfs1(1,0);
        dfs(1,0,1);
        while(m--)
        {
            scanf("%d%d",&x,&y);
            printf("%d\n",dis[x]+dis[y]-2*dis[lca(x,y)]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值