hdu 6447 YJJ's Salesman 树状数组

YJJ's Salesman

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 741    Accepted Submission(s): 211


 

Problem Description

YJJ is a salesman who has traveled through western country. YJJ is always on journey. Either is he at the destination, or on the way to destination.
One day, he is going to travel from city A to southeastern city B. Let us assume that A is (0,0) on the rectangle map and B (109,109) . YJJ is so busy so he never turn back or go twice the same way, he will only move to east, south or southeast, which means, if YJJ is at (x,y) now (0≤x≤109,0≤y≤109) , he will only forward to (x+1,y) , (x,y+1) or (x+1,y+1) .
On the rectangle map from (0,0) to (109,109) , there are several villages scattering on the map. Villagers will do business deals with salesmen from northwestern, but not northern or western. In mathematical language, this means when there is a village k on (xk,yk) (1≤xk≤109,1≤yk≤109) , only the one who was from (xk−1,yk−1) to (xk,yk) will be able to earn vk dollars.(YJJ may get different number of dollars from different village.)
YJJ has no time to plan the path, can you help him to find maximum of dollars YJJ can get.

 

 

Input

The first line of the input contains an integer T (1≤T≤10) ,which is the number of test cases.

In each case, the first line of the input contains an integer N (1≤N≤105) .The following N lines, the k -th line contains 3 integers, xk,yk,vk (0≤vk≤103) , which indicate that there is a village on (xk,yk) and he can get vk dollars in that village.
The positions of each village is distinct.

 

 

Output

The maximum of dollars YJJ can get.

 

 

Sample Input

 

1 3 1 1 1 1 2 2 3 3 1

 

 

Sample Output

 

3

 


题意:

    给你n个村庄的坐标和到达这些村庄可获得的值,但是只能从(xi-1,yi-1)这个坐标达到村庄(x,y),同时如果你在(x,y),你的下一步只能走到(x+1,y),(x,y+1),(x+1,y+1)。问你能获得的最大权值。

 

做法:

    树状数组,更新和询问的都是最大值,向上更新向下询问,所以一开始的时候只要把y坐标进行离散化,用x从小到大,x相同的时候y从小到大来排序,一步步query和add就可以了。具体见代码。


代码如下:

    

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const int maxn=100005;
struct node{
    int x,y,v;
}e[maxn];
bool cmp1(node a,node b){
    return a.y<b.y;
}
bool cmp2(node a,node b){
    if(a.x==b.x) return a.y>b.y;
    return a.x<b.x;
}
int a[maxn];
ll aim[maxn];
int lowbit(ll x){
    return x&(-x);
}
void add(ll x,int pos){
    while(pos<=maxn){
        aim[pos]=max(aim[pos],x);
        pos+=lowbit(pos);
    }
}
ll query(int pos){
    ll ans=0;
    while(pos){
        ans=max(aim[pos],ans);
        pos-=lowbit(pos);
    }
    return ans;
}
int main(){
    int x,y,t,v,n;
    cin>>t;
    while(t--){
        memset(aim,0,sizeof(aim));
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].v);
            a[i]=e[i].y;
        }
        sort(e+1,e+1+n,cmp1);
        sort(a+1,a+1+n);
        int len=unique(a+1,a+1+n)-a;
        for(int i=1;i<=n;i++){
            e[i].y=lower_bound(a+1,a+1+len,e[i].y)-a;
        }
        sort(e+1,e+1+n,cmp2);
        for(int i=1;i<=n;i++){
            ll now=query(e[i].y-1)+e[i].v;
            add(now,e[i].y);
        }
        ll ans=query(maxn-1);
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值