2018中国大学生程序设计竞赛 - 网络选拔赛 1010 YJJ's Salesman2018

Problem Description
YJJ is a salesman who has traveled through western country. YJJ is always on journey. Either is he at the destination, or on the way to destination.
One day, he is going to travel from city A to southeastern city B. Let us assume that A is (0,0) on the rectangle map and B (109,109). YJJ is so busy so he never turn back or go twice the same way, he will only move to east, south or southeast, which means, if YJJ is at (x,y) now (0≤x≤109,0≤y≤109), he will only forward to (x+1,y), (x,y+1) or (x+1,y+1).
On the rectangle map from (0,0) to (109,109), there are several villages scattering on the map. Villagers will do business deals with salesmen from northwestern, but not northern or western. In mathematical language, this means when there is a village k on (xk,yk) (1≤xk≤109,1≤yk≤109), only the one who was from (xk−1,yk−1) to (xk,yk) will be able to earn vk dollars.(YJJ may get different number of dollars from different village.)
YJJ has no time to plan the path, can you help him to find maximum of dollars YJJ can get.

Input
The first line of the input contains an integer T (1≤T≤10),which is the number of test cases.

In each case, the first line of the input contains an integer N (1≤N≤105).The following N lines, the k-th line contains 3 integers, xk,yk,vk (0≤vk≤103), which indicate that there is a village on (xk,yk) and he can get vk dollars in that village.
The positions of each village is distinct.

Output
The maximum of dollars YJJ can get.

Sample Input
1
3
1 1 1
1 2 2
3 3 1

Sample Output
3

这次网赛真的不只是水平的问题,状态也不好,测评姬太卡了,3个小时的时候才发现自己wa了。之后一个小时才做出来两道,自己都慌了,1003看懵逼了,做1010的时候只剩下半个小时,正常发挥还是能做出来的,可惜没如果。开始敲代码只剩下5分钟,最后来不及debug就GG,赛后马上就做出来了,就是记录一个最小值离散化排个序就好了的东西,居然没做。。
都是太菜惹的祸

#include<bits/stdc++.h>
using namespace std;
#define ll long long
const int maxn=1e5+5;
int maxx[maxn],pos[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void add(int pos,int val)
{
    for(int i=pos;i<=maxn;i+=lowbit(i))
        maxx[i]=max(maxx[i],val);
}
int query(int pos)
{
    int ans=0;
    for(int i=pos;i>=1;i-=lowbit(i))
        ans=max(ans,maxx[i]);
    return ans;
}
int a[maxn];
struct node
{
    int x,y,v;
    bool operator< (const node& q)const
    {
        if(x==q.x)
            return y>q.y;
        return x<q.x;
    }
}p[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(maxx,0,sizeof(maxx));
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].v),a[i]=p[i].y;
        sort(a+1,a+1+n);
        int all=unique(a+1,a+1+n)-a-1;
        for(int i=1;i<=n;i++)
            p[i].y=lower_bound(a+1,a+1+all,p[i].y)-a;
        sort(p+1,p+1+n);
        for(int i=1;i<=n;i++)
        {
            int val=query(p[i].y-1)+p[i].v;

            add(p[i].y,val);
        }
        printf("%d\n",query(maxn-1));
    }
    return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值