poj 2230 Watchcow 欧拉回路 每条边跑两次

86 篇文章 0 订阅

Watchcow

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 9136 Accepted: 3990 Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

题意:

       给你n个点,m条边,输出一条每条路都走两次(两次路过的方向不同)的路径,起点任意。

 

做法:

       还是太菜了。。一下子还没想到居然就是这么简单的dfs,对欧拉回路的理解感觉又上了一个层次的样子。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,head[10005],now;
struct node{
    int to,next,flag;
}e[100005];
void add(int u,int v){
    e[now].to=v; e[now].flag=0;
    e[now].next=head[u],head[u]=now++;
}
void dfs(int x){
    for(int i=head[x];~i;i=e[i].next){
        if(!e[i].flag){
            e[i].flag=1;
            dfs(e[i].to);
        }
    }
    printf("%d\n",x);
}
int main(){
    int x,y;
    memset(head,-1,sizeof(head));
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d%d",&x,&y);
        add(x,y);add(y,x);
    }
    dfs(1);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值