1054 求平均值 (20 分)

1054 求平均值 (20 分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

备注:

就是让你去判断字符串是否符合标准然后把符合标准的转换成数值,再取平均值,输出即可。

判断合理性的时候,要看以下几点:

  1. 第一位只能是数和符号
  2. 只能由0-9.构成
  3. 小数点只能出现一次且小数点之后只能有两位小数
  4. 数的取值范围在[-1000,1000],越界不能要

可以直接调用库函数stof(a),把string转化成float格式,更多转换操作见另一篇文章

输出的时候注意格式,仔细审题,当只有一个输出的时候时number单数而不是numbers,不然会错一个。输出的时候保留两位小数,通过.2f即可实现


AC例程
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<map>
#include<queue>
#include<sstream>
using namespace std;

int judge(string a)
{
    int count =0;
    if(a.length()>8)return 2;
    if(a[0]=='-'||(a[0]>='0'&&a[0]<='9')){
        for(int i=1;i<a.length();i++)
        {
            if((a[i]<'0'&&a[i]!='.')||a[i]>'9')return 3;
            if(a[i]=='.')
            {
                if(count==0){
                    count++;
                    if(a.length()-i-1>2) return 4;
                    }
                else 5;  
            }
            
        }
    }else return 6;
    return 1;
}
int main(){
#ifdef ONLINE_JUDGE
#else
    freopen("in.txt","r",stdin);
#endif
int n;
string a;
while(cin>>n){
    int count=0;
    float sum=0;
while(n--)
    {
        a="";cin>>a;
        if(judge(a)==1)
        {
            if(stod(a)<=1000&&stod(a)>=-1000)
            {count++;
            sum+=stod(a);
            }else cout<<"ERROR: "<<a<<" is not a legal number"<<endl;
        }else {
            cout<<"ERROR: "<<a<<" is not a legal number"<<endl;
        }
    }
    if (count>1){
        cout<<"The average of ";cout<<count;
        cout<<" numbers is ";printf("%.2f\n",sum/count);
    }
    else if(count==1)
    {
        cout<<"The average of ";cout<<count;
        cout<<" number is ";printf("%.2f\n",sum/count);
    }
    else cout<<"The average of 0 numbers is Undefined"<<endl;
}
return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值