Period

 

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

 

Sample Input

3

aaa

12

aabaabaabaab

0

 

Sample Output

Test case #1

2 2

3 3

 

Test case #2

2 2

6 2

9 3

12 4

题意:求一定长度字符串中循环节的个数

比如说样例aabaabaabaab,它的输出2  2  指的就是aa,它的尺寸是2,循环节就是a,循环次数是2。输出6  2是指aabaab, 它的尺寸是6, 循环节是aab, 循环次数是2。后边的两个也是同样的意思,要注意尺寸的大小都是从字符串的开头开始算的。

注意输出格式   加空行!!

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<map>
#include<queue>
#include<vector>
#include<stack>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N=1000005;

int n,Next[N];
char a[N];

void get_Next()
{
    memset(Next,0,sizeof(Next));
    int i=0,j=-1;
    Next[0]=-1;
    while(i<n)
    {
        if(j==-1||a[i]==a[j])
            Next[++i]=++j;
        else
            j=Next[j];
    }
}

int main()
{
    int T=0;
    while(~scanf("%d",&n)&&n)
    {
        int i,k;
        scanf("%s",a);
        get_Next();
        printf("Test case #%d\n",++T);//注意输出格式
        for(i=1;i<=n;i++)
        {
            if(!Next[i])
                continue;
            k=i-Next[i];
            if(i%k==0)
                printf("%d %d\n",i,i/k);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值