PAT1147 Heaps (30分)堆,树的DFS,层次遍历转后序

1 篇文章 0 订阅
1 篇文章 0 订阅

PAT 1147 Heaps(30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
题目大意

给出一个堆(由树的形式构成)的层次遍历,要求编程判断是一个大顶堆还是小顶堆又或者是非堆。并输出该树的后序遍历。

思路

1.首先要进行层次转后序,因此采用DFS遍历。大致的DFS框架可以打好。
2.判断大顶堆或者小顶堆时,可以在DFS中进行。具体的方法是:

  • 设置两个布尔型变量isMax和isMin,均初始化为false。
  • 如果一个根结点大于等于其子节点,就令isMax=true;如果一个根结点的小于等于其子节点,就令isMin=true。
  • 执行完DFS以后,如果isMax和isMin都为true,则说明这不是一个堆;若isMax为true,则为大顶堆;若isMin为true,则为小顶堆。
代码
#include<iostream>
#include<set>
#include<vector>
#include<algorithm>
#include<queue>
#include<math.h>
#include<map>
#include<stack>
#include<string.h>
#include<string>
#include<limits.h>
using namespace std;

vector<int> heap, post;
int m, n;

bool isMax = false, isMin = false;
void dfs(int root)
{
	if (root >= n) return;
	if (root * 2 + 1 < n) {
		if (heap[root] >= heap[root * 2 + 1])  isMax = true;
		else if (heap[root] <= heap[root * 2 + 1]) isMin = true;
		dfs(root * 2 + 1);
	}
	if (root * 2 + 2 < n) {
		if (heap[root] >= heap[root * 2 + 2])  isMax = true;
		else if (heap[root] <= heap[root * 2 + 2]) isMin = true;
		dfs(root * 2 + 2);
	}
	post.push_back(heap[root]);

}

int main()
{
	cin >> m >> n;
	int num;
	while (m--) {
		isMax = false; isMin = false;
		heap.clear(); post.clear();
		for (int i = 0; i < n; i++) {
			cin >> num;
			heap.push_back(num);
		}
		dfs(0);
		if (isMax&&isMin) printf("Not Heap\n");
		else printf("%s Heap\n", isMax ? "Max" : "Min");
		for (int i = 0; i < post.size(); i++) {
			if (i == 0) printf("%d", post[i]);
			else printf(" %d", post[i]);
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值