1147 Heaps(30 分)

1147 Heaps(30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

emmmm这题就是判断 利用下vector 即可 还挺水的

pat对Java真的很不友好 动不动就超时 让我这个初学Java的娃娃练题动不动就超时心塞塞

这边有一长知识的地方离散中(忘记啦) 完全二叉树是指 父节点是满的叶子点除了右边的可能空左边的一定是满

求叶子节点就是  m - (m / 2)

然而父子节点 m/2  嘻嘻嘻差点都忘记了 心塞塞

C++代码:

#include<bits/stdc++.h>
using namespace std; 
int a[10000],n,m;
vector<int>vc;	
bool Minheap()
{
	//叶子节点   num = m - (m/2) 所以非叶子节点为 m/2 
	for(int i = 1; i <= m/2; i++ )
	{
		if( i * 2 <= m) { //他的子节点要存在
			if(a[i] >= a[i * 2]) //其次如果说父节点大于子节点就getover
				return false;
		}
		if( i * 2 + 1 <= m) { //他的子节点要存在
			if(a[i] >= a[i * 2 + 1 ])//其次如果说父节点大于子节点就getover
				return false;
		}
	}
	return true;
}
bool Maxheap()
{
	//叶子节点   num = m - (m/2) 所以非叶子节点为 m/2 
	for(int i = 1; i <= m/2; i++ )
	{
		if( i * 2 <= m) { //他的子节点要存在
			if(a[i] <= a[i * 2]) //其次如果说父节点小于子节点就getover
				return false;
		}
		if( i * 2 + 1 <= m) { //他的子节点要存在
			if(a[i] <= a[i * 2 + 1 ])//其次如果说父节点小于子节点就getover
				return false;
		}
	}
	return true;
}
void Postorder(int i)
{
	if(i <= m)
	{
		Postorder(i * 2);
		Postorder(i * 2 + 1);
		vc.push_back(a[i]);
	}
}
void judge()
{
	if( Minheap() )
		puts("Min Heap"); 
	else if (Maxheap()) 
		puts("Max Heap");
	else 
		puts("Not Heap");
	Postorder(1);
	for(int i = 0; i< vc.size();i++)
		printf("%d%c",vc[i]," \n"[i==vc.size()-1]);
}
int main() {
	scanf("%d%d",&n,&m);
	while(n-- > 0)
	{
		vc.clear();
		for(int i = 1; i <= m; i++)
			scanf("%d",&a[i]);//到此输入结束之后就是开始判断是否是哪种堆了
		judge();
	}
	return 0;
}

Java代码: 最后一个测试点超时了 看来的学习下Java如何处理超时间的了奥

import java.util.Scanner;
import java.util.Vector;
public class Main {
	static Scanner sc = new Scanner (System.in);
	static int a[] = new int [10000];
	static int n,m;
	static Vector <Integer> vc = new Vector <Integer>();
	static boolean Minheap()
	{
		//叶子节点   num = m - (m/2) 所以非叶子节点为 m/2 
		for(int i = 1; i <= m/2; i++ )
		{
			if( i * 2 <= m) { //他的子节点要存在
				if(a[i] >= a[i * 2]) //其次如果说父节点大于子节点就getover
					return false;
			}
			if( i * 2 + 1 <= m) { //他的子节点要存在
				if(a[i] >= a[i * 2 + 1 ])//其次如果说父节点大于子节点就getover
					return false;
			}
		}
		return true;
	}
	static boolean Maxheap()
	{
		//叶子节点   num = m - (m/2) 所以非叶子节点为 m/2 
		for(int i = 1; i <= m/2; i++ )
		{
			if( i * 2 <= m) { //他的子节点要存在
				if(a[i] <= a[i * 2]) //其次如果说父节点小于子节点就getover
					return false;
			}
			if( i * 2 + 1 <= m) { //他的子节点要存在
				if(a[i] <= a[i * 2 + 1 ])//其次如果说父节点小于子节点就getover
					return false;
			}
		}
		return true;
	}
	static void Postorder(int i)
	{
		if(i <= m)
		{
			Postorder(i * 2);
			Postorder(i * 2 + 1);
			vc.add(a[i]);
		}
	}
	static void judge()
	{
		if( Minheap() )
			System.out.println("Min Heap");
		else if (Maxheap()) 
			System.out.println("Max Heap");
		else 
			System.out.println("Not Heap");
		Postorder(1);
		for(int i = 0; i< vc.size();i++)
		{
			System.out.print(vc.get(i));
			if(i == vc.size() - 1)
				System.out.println();
			else 
				System.out.print(" ");
		}
	}
	public static void main(String[] args) {
		n = sc.nextInt();
		m = sc.nextInt();
		
		while(n-- > 0)
		{
			vc.clear();
			for(int i = 1; i <= m; i++)
				a[i] = sc.nextInt();//到此输入结束之后就是开始判断是否是哪种堆了
			judge();
		}
		sc.close();
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值