D - Bus System

题目:
ecause of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.
在这里插入图片描述

Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
Sample Input
2
1 2 3 4 1 3 5 7
4 2
1
2
3
4
1 4
4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10
1 4
Sample Output
Case 1:
The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.
Case 2:
Station 1 and station 4 are not attainable.

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAX 110
#define NIL -1
typedef long long ll;
int main()
{
    ll L1,L2,L3,L4,C1,C2,C3,C4,a[MAX],mp[MAX][MAX];//一定要long long
    int num,n,m,c,d;
    scanf("%d",&num);
    for(int i = 1;i <= num;i++){
        scanf("%lld%lld%lld%lld%lld%lld%lld%lld",&L1,&L2,&L3,&L4,&C1,&C2,&C3,&C4);
        scanf("%d%d",&n,&m);
        //初始化
        memset(a,0,sizeof(a));
        memset(mp,0,sizeof(mp));
        //邻接矩阵保存图
        for(int j = 0;j < n;j++){
            scanf("%lld",&a[j]);
            for(int k = 0;k <= j;k++){
                mp[k][j] = abs(a[k] - a[j]);
                if(mp[k][j] == 0) mp[k][j] = mp[j][k] = 0;//原地打转不花钱
                else if(mp[k][j] > 0 && mp[k][j] <= L1) mp[k][j] = mp[j][k] = C1;
                else if(mp[k][j] > L1 && mp[k][j] <= L2) mp[k][j] = mp[j][k] = C2;
                else if(mp[k][j] > L2 && mp[k][j] <= L3) mp[k][j] = mp[j][k] = C3;
                else if(mp[k][j] > L3 && mp[k][j] <= L4) mp[k][j] = mp[j][k] = C4;
                else mp[k][j] = mp[j][k] = -1;//距离超过L4
            }
        }
        //Floyd算法
        for(int j = 0;j < n;j++){
            for(int k = 0;k < n;k++){
                for(int u = 0;u < n;u++){
                    if(mp[k][j] != -1 && mp[j][u] != -1){//要是距离太长花再多钱也去不了那就不考虑
                        if(mp[k][u] == -1 || mp[k][u] > mp[k][j] + mp[j][u])
                            mp[k][u] = mp[k][j] + mp[j][u];
                    }
                }
            }
        }
        //question(一定要注意格式)
        cout << "Case " << i << ":" << endl;
        for(int j = 0;j < m;j++){
            scanf("%d%d",&c,&d);
            if(mp[c - 1][d - 1] != -1)
            cout << "The minimum cost between station " << c
            << " and station " << d << " is " << mp[c - 1][d - 1] << "." << endl;
            else cout << "Station " << c
            << " and station " << d << " are not attainable." << endl;
        }
    }
    return 0;
}

这道题wa了好几次才过了,首先这道题要求的是小花费,这里可以类比成最短路径的题来做,因为要求输出多个不同起点走到终点的最小花费,所以就使用floyd算法。其次,由于花费相加之和可能会超过int的最大值,所以一定要使用long long型,而且走不到的地方都要赋值为-1(当然也可以赋值一个极大值,但是很可能因为那个值不够大而导致wa)。最后一定要注意输出的格式!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值