HDU - 2680 Choose the best route

题目:
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1
Sample Output
1
-1
代码如下:

#include<bits/stdc++.h>
using namespace std;
#define MAX 1005
#define NIL 0x3f3f3f3f
int mp[MAX][MAX],dis[MAX];
bool vis[MAX];
int n,m,s;
void Dijkstra()
{
    memset(dis,NIL,sizeof(dis));
    memset(vis,false,sizeof(vis));
    dis[0] = 0;
    priority_queue<int> q;
    q.push(0);
    while(!q.empty()){
        int flag = q.top();
        q.pop();
        vis[flag] = true;
        for(int i = 0;i <= n;i++){
            if(dis[i] > dis[flag] + mp[flag][i]){
                dis[i] = dis[flag] + mp[flag][i];
                q.push(i);
            }
        }
    }
}
int main()
{
    int x,y,z,k;
    while(~scanf("%d%d%d",&n,&m,&s)){
        memset(mp,NIL,sizeof(mp));
        for(int i = 0;i < m;i++){
            scanf("%d%d%d",&x,&y,&z);
            if(mp[x][y] > z) mp[x][y] = z;
        }
        scanf("%d",&k);
        for(int i = 0;i < k;i++){
            scanf("%d",&x);
            mp[0][x] = 0;
        }
        Dijkstra();
        if(dis[s] == 0x3f3f3f3f) cout << "-1" << endl;
        else cout << dis[s] << endl;
    }
    return 0;
}

题意:
有多组测试用例,第一行给定点的个数,路线个数以及终点序号,之后每行是路线的端点和权值。然后告诉你由k个地方你可以作为出发地点,让你求达到终点的最短距离。
思路:
只要自己设置一个点序号为0,然后让0结点到起点的距离都为0。求结点0到终点的最短路径,用Dijkstra算法即可。这道题是卡cin的,所以大家都用scanf吧!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值