2016青岛icpc网络C - Pocky

Pocky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2306    Accepted Submission(s): 1247


 

Problem Description

Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

 

 

Input

The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

 

 

Output

For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

 

 

Sample Input

 

6 1.0 1.0 2.0 1.0 4.0 1.0 8.0 1.0 16.0 1.0 7.00 3.00

 

 

Sample Output

 

0.000000 1.693147 2.386294 3.079442 3.772589 1.847298

 

 

Source

2016ACM/ICPC亚洲区青岛站-重现赛(感谢中国石油大学)

 

 

Recommend

jiangzijinh额2015

 

 


https://blog.csdn.net/GreyBtfly/article/details/80579481

这是一位大佬的数学解题过程。

这道题在比赛的时候是找数字规律后再猜出最后的数学公式做出来的,数学素养真的很重要啊!要要不然连看到一些数字都无法感到敏感啊! 比如说:
log10(2):0.301030
log10(3):0.477121
log10(5):0.698970
log10(7):0.845098
ln(2):0.693147
ln(3):1.098612
ln(5):1.609438


ps:最近在学概率论,对期望值的求法也有所了解所以在理解题意方面也有帮助。
感谢队友一直陪伴分析数据!

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

double L, d;

int main()
{
    int N;
    cin >> N;

    while (N--)
    {
        cin >> L >> d;

        if (L <= d)
        {
            cout << "0.000000\n";
        }
        else
        {
            printf("%.6f\n", 1 + log(L / d));
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值