【个人代码及思路】PAT甲级:1001 A+B Format (20分)

PAT (Advanced Level) Practice

1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

个人代码:

#include<stdio.h>

void sumdigit(int sum0);

int main()
{
    int a,b,sum,sum0; //sum0是sum的绝对值

    scanf("%d %d", &a, &b);

    sum = a + b;
    sum0 = sum;

    //输出符号
    if(sum < 0)
    {
        sum0 = -sum;
        printf("-");
        sumdigit(sum0);
    } else if(sum == 0) {
        printf("0");
    } else {
        sumdigit(sum0);
    }

    return 0;
}

//sum按位输出
void sumdigit(int sum0)
{
    int mask = 1; //
    int digit =1;
    int temp = sum0;
    int fir = 0;

    //确定sum0的位数digit
    while(temp / 10 > 0)
    {
        mask *= 10;
        temp /= 10;
        digit ++;
    }

    //根据位数digit输出
    for(int i = 0; i < digit;)
    {
        fir = sum0 / mask;
        sum0 %= mask;
        printf("%d", fir);
        if((digit % 3 == 1) && (digit > 3))
        {
            printf(",");
        }
        digit --;
        mask /= 10;
    }

}

思路提示:

先将两数相加,取其值的绝对值。对每一位分解输出,并检查当前位数%3是否等于1,如果是则额外输出“,”。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值