PAT (Advanced Level) Practice
1001 A+B Format (20分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
个人代码:
#include<stdio.h>
void sumdigit(int sum0);
int main()
{
int a,b,sum,sum0; //sum0是sum的绝对值
scanf("%d %d", &a, &b);
sum = a + b;
sum0 = sum;
//输出符号
if(sum < 0)
{
sum0 = -sum;
printf("-");
sumdigit(sum0);
} else if(sum == 0) {
printf("0");
} else {
sumdigit(sum0);
}
return 0;
}
//sum按位输出
void sumdigit(int sum0)
{
int mask = 1; //
int digit =1;
int temp = sum0;
int fir = 0;
//确定sum0的位数digit
while(temp / 10 > 0)
{
mask *= 10;
temp /= 10;
digit ++;
}
//根据位数digit输出
for(int i = 0; i < digit;)
{
fir = sum0 / mask;
sum0 %= mask;
printf("%d", fir);
if((digit % 3 == 1) && (digit > 3))
{
printf(",");
}
digit --;
mask /= 10;
}
}
思路提示:
先将两数相加,取其值的绝对值。对每一位分解输出,并检查当前位数%3是否等于1,如果是则额外输出“,”。