POJ 1827A Bunch Of Monsters (贪心)

Description

Background 
Jim is a brave explorer. One day, he set out for his next destination, a mysterious hill. When he arrived at the foot of the hill, he was told that there were a bunch of monsters living in that hill, and was dissuaded from continuing his trip by the residents near the hill. Nevertheless, our Jim was so brave that he would never think of giving up his exploration. 
The monsters do exist! When he got into that hill, he was caught by a bunch of fearful monsters. 
Fortunately, the monsters didn’t plan to kill him or eat him for they were planning a big party. They wanted to invite Jim, a clever human being, to their party, in order to let human beings know that the monsters also have wonderful parties. 
Problem 
At the end of the party, the monsters promised that, after the last game, they would set Jim free. The game is described as follow: 
1. There are a great many boxes of treasure, which are numbered from 1 to X. One box has the only one number; one number can only appear on one box. Furthermore, we can assume that X is INFINITY, because the monsters have got a lot of treasure from the men they caught. 
2. There are N monsters in this game. Each picks up a card randomly. After that, he / she (it?) opens it, getting a positive integer number d[i], and cannot change it or pick up another card again. The range of d[i] is from 1 to M. If the i-th monster get the number d[i], he can only get the treasure box numbered equal to or less than d[i]. What’s more, one box only can be distributed to one monster; one monster can only get one box. 
3. Of course, there are many ways to distribute the boxes to the monsters when N monsters get their numbers; and not every monster can get a box in many cases. Jim has the right to make the arrangement; however, he also knows that the monsters that don’t get the boxes will also punish him. 
Jim knows the strength of the N monsters. The i-th one has the strength s[i]. We call the sum of strength s[i] of all the monsters that don’t get the boxes --- the DAMAGE to Jim. Your task is to help Jim find out the minimum DAMAGE to him. 

Input

The input consists of several test cases. In the first line of each test case, there are two positive integers N and M (1<=N<=50000, 1<=M<=50000), indicating the number of monsters and the range of numbers the monsters possibly get on the cards. Then there are N integers d[i] (1<=d[i]<=M) in the following lines, which are the numbers those monsters got. And in the rest lines of one test case, there are other N positive integers s[i] (1<=s[i]<=20000), indicating the strength of each monsters. The test case starting with 2 zeros is the final test case and has no output.

Output

For each test case, print your answer, the minimum DAMAGE, in one line without any redundant spaces.

Sample Input

1 1
1
1
7 7
6 4 4 2 3 4 3
10 70 20 60 30 50 40
0 0

Sample Output

0
50

Source

Atlas of rruucc@POJ

解题思路:

这是一道典型的贪心的题,因为要求伤害最低,所以只要对怪物根据力量的大小从大到小进行排序,然后先让力量高的拿盒子,再把没有拿到盒子的怪兽力量求和即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 50000+50
using namespace std;


struct monster
{
    int nu,len;  //nu为怪物拿到的号码,len为怪兽的力量
    bool operator <(const monster &n) const{
        return len > n.len;
    }
}monsters[maxn];

bool vis[maxn];

int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        if(!m&&!n)
            break;
        for(int i = 0;i < m;i++){
            scanf("%d",&monsters[i].nu);
        }
        for(int i = 0;i < m;i++){
            scanf("%d",&monsters[i].len);
        }
        sort(monsters,monsters+m);
        memset(vis,0,sizeof(vis));
        long ans=0;
        for(int i=0;i<m;i++)
        {
            int f=0;
            for(int j=monsters[i].nu;j>=1;j--)
            {
                if(!vis[j])
                {
                    vis[j]=1;
                    f=1;
                    break;
                }
            }
            if(!f)
                ans+=monsters[i].len;
        }
        printf("%ld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值