1118 Birds in Forest (25 分)(并查集)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4

3 10 1 2

2 3 4

4 1 5 7 8

3 9 6 4

2

10 5

3 7

Sample Output:

2 10

Yes

No

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <stack>
#include <cmath>
using namespace std;
const int maxn=10010;
vector<int> father(maxn,-1);
int findFather(int n){//找爸爸
    if(father[n]==-1) return n;
    else{
        int f=findFather(father[n]);
        father[n]=f;
        return f;
    }
}
void uni(int a,int b){
    int fa=findFather(a);
    int fb=findFather(b);
    if(fa!=fb) father[fa]=fb;//把a放到b里面
}
int main()
{
    int n,k,b1,b2,maxb=0;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>k>>b1;
        maxb=max(b1,maxb);
        for(int j=0;j<k-1;j++){
            cin>>b2;
            maxb=max(b2,maxb);
            uni(b1, b2);
        }
    }
    int cnt=0;
    for(int i=1;i<=maxb;i++){
        if(father[i]==-1) cnt++;
    }
    cout<<cnt<<" "<<maxb<<endl;
    int q;
    cin>>q;
    for(int i=0;i<q;i++){
        int a,b;
        cin>>a>>b;
        if(findFather(a)==findFather(b)) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值