1022 Digital Library (30 分)(map映射,STL,输入的使用)

92 篇文章 0 订阅

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10

4

) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3

1111111

The Testing Book

Yue Chen

test code debug sort keywords

ZUCS Print

2011

3333333

Another Testing Book

Yue Chen

test code sort keywords

ZUCS Print2

2012

2222222

The Testing Book

CYLL

keywords debug book

ZUCS Print2

2011

6

1: The Testing Book

2: Yue Chen

3: keywords

4: ZUCS Print

5: 2011

3: blablabla

Sample Output:

1: The Testing Book

1111111

2222222

2: Yue Chen

1111111

3333333

3: keywords

1111111

2222222

3333333

4: ZUCS Print

1111111

5: 2011

1111111

2222222

3: blablabla

Not Found

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
map<string,set<int>> title,author,key,pub,year;
void query(map<string,set<int>> &m,string &str){
    if(m.find(str)!=m.end()){
        for(auto it=m[str].begin();it!=m[str].end();it++)
            printf("%07d\n",*it);
    }else{
        printf("Not Found\n");
    }
}
int main(){
    int n,m,id,num;
    scanf("%d",&n);
    string title1,author1,key1,pub1,year1;
    for(int i=0;i<n;i++){
        scanf("%d\n",&id);      //注意这里要加\n
        getline(cin,title1);
        title[title1].insert(id);
        getline(cin,author1);
        author[author1].insert(id);
        while(cin>>key1){
            key[key1].insert(id);
            char c=getchar();
            if(c=='\n') break;
        }
        getline(cin,pub1);
        pub[pub1].insert(id);
        getline(cin,year1);
        year[year1].insert(id);
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d: ",&num);
        string temp;
        getline(cin,temp);
        cout<<num<<": "<<temp<<endl;
        if(num==1) query(title,temp);
        else if(num==2) query(author,temp);
        else if(num==3) query(key,temp);
        else if(num==4) query(pub,temp);
        else if(num==5) query(year,temp);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值