1130 Infix Expression (25 分)(dfs,数的遍历,中序)

92 篇文章 0 订阅

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

 

 

Figure 1

Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8

* 8 7

a -1 -1

* 4 1

+ 2 5

b -1 -1

d -1 -1

- -1 6

c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8

2.35 -1 -1

* 6 1

- -1 4

% 7 8

+ 2 3

a -1 -1

str -1 -1

871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
struct node{
    string data;
    int l,r;
}v[100];
string dfs(int root){
    if(v[root].l==-1&&v[root].r==-1) return v[root].data;
    else if(v[root].l==-1&&v[root].r!=-1) return "("+v[root].data+dfs(v[root].r)+")";
    else if(v[root].l!=-1&&v[root].r==-1) return "("+dfs(v[root].l)+v[root].data+")";
    else return "("+dfs(v[root].l)+v[root].data+dfs(v[root].r)+")";
}
int main() {
    int n;
    cin>>n;
    int have[100]={0};
    for(int i=1;i<=n;i++){
        cin>>v[i].data>>v[i].l>>v[i].r;
        if(v[i].l!=-1) have[v[i].l]=1;
        if(v[i].r!=-1) have[v[i].r]=1;
    }
    int root=1;
    while(have[root]==1) root++;
    string ans=dfs(root);
    if(ans[0]=='(') ans=ans.substr(1,ans.size()-2);
    cout<<ans;
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值