Soundex编码(Soundex)

  • 题目描述:

Soundex编码方法根据单词的拼写将单词进行分组,使得同一组的单词发音很接近。例如,“can"与"khawn”,"con"与"gone"在Soundex编码下是相同的。
Soundex编码方法将每个单词转换成一串数字,每个数字代表一个字母。规则如下:
1代表B,F,P或V;
2代表C,G,J,K,Q,S,X或Z;
3代表D或T;
4代表L;
5代表M或N;
6代表R。
而字母A,E,I,O,U,H,W和Y不用任何数字编码,并且相邻的、具有相同编码值的字母只用一个对应的数字代表。具有相同Soundex编码值的单词被认为是相同的单词。

  • 输入描述:

输入文件中的每行为一个单词,单词中的字母都是大写,每个单词长度不超过20个字母。

  • 输出描述:

对输入文件中的每个单词,输出一行,为该单词的Soundex编码

  • 样例输入:

KHAWN
PFISTER
BOBBY

  • 样例输出:

25
1236
11

  • 代码

#include<iostream>
#include <stdio.h>
using namespace std;
int main() 
{
	char ch[21];
	int i,j,s[21],k;
	while(gets(ch)!=NULL){
		i=0;j=0;
		while(ch[i]!='\0'){
			switch (ch[i]){					
				case 'B':case 'F':case 'P':case 'V':{
					s[j]=1;
					j++;
					break;
				}
				case 'C':case 'G':case 'J':case 'K':case 'Q':
				case 'S':case 'X':case 'Z':{
					s[j]=2;
					j++;
					break;
				}
				case 'D':case 'T':{
					s[j]=3;
					j++;
					break;
				}
				case 'L':{
					s[j]=4;
					j++;
					break;
				}
				case 'M':case 'N':{
					s[j]=5;
					j++;
					break;
				}
				case 'R':{
					s[j]=6;
					j++;
					break;
				}
				case 'A':case 'E':case 'I':case 'O':
				case 'U':case 'W':case 'Y':{
					s[j]=0;
					j++;
					break;
				}			
			}
			i++;
			//cout<<s[j-1];
		}
		k=0;
		for(j=0;j<i;j++){
			if(s[j]==0){
				k=s[j];
			}
			else{
				if(s[j]!=k){
					//s[i1]=s[j];
					//i1++;
					cout<<s[j];
					k=s[j];
				}
			}
		}
		cout<<endl;
		
	}
	return 0;	
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Soundex算法是一种用于字符串匹配的算法,它可以将一个单词转换成一个固定长度的编码(通常为4个字符),以便于比较单词的相似性。以下是用C语言实现Soundex算法的代码示例: ```c #include <stdio.h> #include <ctype.h> #include <string.h> void soundex(char *s, char *soundex_code) { const char *soundex_table = "01230120022455012623010202"; int i, j, prev_code, curr_code; /* Convert the first letter to uppercase */ soundex_code[0] = toupper(s[0]); /* Convert the remaining letters to their corresponding Soundex codes */ prev_code = soundex_table[s[0] - 'A']; j = 1; for (i = 1; i < strlen(s); i++) { curr_code = soundex_table[s[i] - 'A']; if (curr_code != '0' && curr_code != prev_code) { soundex_code[j++] = curr_code; } prev_code = curr_code; } /* Pad the Soundex code with zeros if it is less than 4 characters */ while (j < 4) { soundex_code[j++] = '0'; } /* Terminate the string */ soundex_code[j] = '\0'; } int main() { char s[100], soundex_code[5]; printf("Enter a word: "); fgets(s, sizeof(s), stdin); s[strcspn(s, "\n")] = '\0'; soundex(s, soundex_code); printf("Soundex code: %s\n", soundex_code); return 0; } ``` 在这个示例中,我们首先定义了一个Soundex表格(soundex_table),它将字母映射到它们的Soundex代码。然后,我们实现了一个名为“soundex”的函数,它接受一个输入字符串和一个输出字符串作为参数,并将输入字符串转换为其对应的Soundex代码,存储在输出字符串中。在函数中,我们首先将输入字符串的第一个字母转换为大写字母,并将其存储在输出字符串的第一个位置上。然后,我们将剩余的字母转换为它们对应的Soundex代码,并将其存储在输出字符串中。如果两个相邻的字母具有相同的Soundex代码,则只存储一个代码。最后,我们将输出字符串填充到4个字符,并在结尾处添加一个空字符。在主函数中,我们从用户输入中获取一个单词,并将其传递给“soundex”函数,以获取其对应的Soundex代码。最后,我们将Soundex代码打印到控制台上。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值