[PTA]02-线性结构4 Pop Sequence

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, ..., NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
 
  • 时间限制:400ms
  • 内存限制:64MB
  • 代码长度限制:16kB
  • 判题程序:系统默认
  • 作者:陈越
  • 单位:浙江大学
解题思路:
按照给出的序列模拟进栈出栈,如果最终栈不为空,说明给出的序列不是由该栈产生。
1. 将给出的N个数压入栈t(使序列的第一个元素为栈顶,最后一个元素为栈底).
2. 开辟一个空栈s,需要按照1--N的顺序依次压入栈s,每次压栈后都要判断:如果栈s的栈顶元素和栈t的栈顶元素相同,说明该元素可以由栈s产生,则弹出栈s和栈t的栈顶元素
3. 如果栈s和栈t的栈顶元素不同,则继续压入栈s。注意当栈s满的时候不能压栈,需要继续判断,如果此时s的栈顶元素仍然无法和t的栈顶元素匹配,则说明该序列不匹配。

C语言顺序栈实现
#include <stdio.h>

#define MAXSIZE 1000

typedef struct{
    int data[MAXSIZE];
    int top;
}SqStack;

int InitStack(SqStack *s)
{
    s->top = -1;
    return 0;
}

int Push(SqStack *s, int e)
{
    if(s->top==MAXSIZE)return 1;
    s->top++;
    s->data[s->top]=e;
    return 0;
}

int Pop(SqStack *s){
    int e;
    if(s->top==-1)return 1;
    e=s->data[s->top];
    s->top--;
    return e;
}

int main()
{
    int m, n, k,i,h;
    SqStack s,t;
    scanf("%d%d%d",&m,&n,&k);
    while(k--){
        InitStack(&s);/*初始化栈s和栈t*/
        InitStack(&t);
        for(i=n-1;i>=0;i--){    /*将给出的序列依次压入栈t中(首元素为栈顶)*/
            scanf("%d",&(t.data[i]));
        }
        t.top=n-1;
        i=0;
        while(i<=n){    /*模拟进栈出栈*/
            if(s.data[s.top]==t.data[t.top]&&s.top!=-1){/*如果s的栈顶元素和t的栈顶元素相同*/
                Pop(&s);
                Pop(&t);
            }else if(s.top<m-1 && i<n){/*如果不相同且s栈未满*/
                i++;
                Push(&s,i);
            }else{  /*以上两种情况都不匹配则说明匹配失败*/
                break;
            }
        }
        if(s.top==-1 && t.top==-1){
            printf("YES\n");
        }else{
            printf("NO\n");
        }

    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值