[湖南大学程序设计实训训练作业三]3.魔咒词典(字符串切割+map)

【问题描述】

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

【输入形式】

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含非负整数N(0=<N<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

【输出形式】

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

【样例输入】

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

【样例输出】

light the wand
accio
what?
what?

题解

思路

  • 1.魔咒名字和功能中间会有空格,所以,首先我们要getline获取整行
  • 2.find得到[]括号的位置,可以substr切割出name和function
  • 3.使用map双向绑定
  • 4.查询输入直接map查询,输出结果即可
  • 注意:查询输入如果是name要进行输入查询处理,去掉[]括号
  • 注意:如果查询结果是name,是没有括号的!(这里我们在存map的时候已经处理好了)

代码

#include<iostream>
#include<string>
#include<map>
using namespace std;
int main(){
	string temp;
	map<string,string> dict;
	while(getline(cin,temp)){//获取一行的信息 
		if(temp=="@END@") break;
		int l_pos=temp.find('[');
		int r_pos=temp.find(']');//获取左右括号的位置 
		string name=temp.substr(l_pos+1,r_pos-l_pos-1);
		string function=temp.substr(r_pos+2);//用切割的方法获取,因为name和function中可能有空格 
		dict[name]=function;//
		dict[function]=name;//双向绑定 
	}
	int n;
	cin>>n;
	cin.ignore();//忽略一个换行 
	while(n--){
		getline(cin,temp);//这里不一定是name,输入的也可能是function
		/************输入处理*********************/
		if(temp[0]=='['){
			temp=temp.substr(1,temp.length()-2);//存储的是没有括号的!所以这里要去掉括号 
		} 
		/*****************************************/
		if(dict.find(temp)!=dict.end()){
			cout<<dict[temp]<<endl;
		}else{
			cout<<"what?"<<endl;
		} 
	} 
	return 0;
} 
  • 5
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值