【算法笔记】Day of Week

Day of Week

时间限制: 1 Sec  内存限制: 32 MB
提交: 2252  解决: 692
[提交][状态][讨论版][命题人:外部导入]

题目描述

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入

21 December 2012
5 January 2013

样例输出

Friday
Saturday

就是输入一个日期,求它是星期几。与1年1月1日比较看差多少天即可。

# include <stdio.h>
# include <string.h>
 
int isleapyear(int a){
    return a%4 == 0 && a%100 != 0 || a % 400 == 0;
}
int main(void)
{
    char month[20];
    int day, year, k, d, i, sum;
    int q[2][13] = {{0,31,28,31,30,31,30,31,31,30,31,30,31},{0,31,29,31,30,31,30,31,31,30,31,30,31}};
    char a[15][20] = {"0","January","February","March","April","May","June","July","August","September","October","November","December"};
    char b[10][20] = {"Monday","Tuesday","Wednesday","Thursday","Friday","Saturday","Sunday"};
    while (~ scanf("%d %s %d", &day, month, &year)){
        sum = 0;
        for (i = 1; i < year; i ++){
            if (isleapyear(i) == 1)
            sum += 366;
            else
            sum += 365;
        }
        for (k = 1; k <= 12; k ++){
            if (strcmp(month, a[k]) == 0)
            break;
        }
        d = qwe(year);
        for (i = 1; i < k; i ++){
            sum += q[d][i];
        }
        sum += day;
        if (sum%7 == 0)
        printf("Sunday\n");
        else
        printf("%s\n", b[sum%7 -1]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

白驹_过隙

听说打赏的都进了福布斯排行榜

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值