OJ上的Presentation Error

A+B for Input-Output Practice (VIII)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 222083 Accepted Submission(s): 65417

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6
注意事项:OJ上的评审是很严格的,我们要完全根据题意来,下列我们根据这题来观察这段代码的不同之处
AC代码:

#include<iostream>
using namespace std;
int main(){
    int M;              //数据组数
    int N;               //每组数据的个数
    int a[100];
    cin>>M;            //数据组数
    for(int i=1;i<=M;i++){
        cin>>N;
        int sum=0;
        for(int j=1;j<=N;j++){
            cin>>a[j];
            sum=sum+a[j];
        }
        cout<<sum<<endl;
        if(i==M)
        break;
        cout<<endl;
    }
    return 0;
}

Presentation Error代码:

#include<iostream>
#include<cmath>
using namespace std;
int main(){
    int M;              //数据组数
    int N;               //每组数据的个数
    int a[100];
    cin>>M;            //数据组数
    for(int i=1;i<=M;i++){
        cin>>N;
        int sum=0;
        for(int j=1;j<=N;j++){
            cin>>a[j];
            sum=sum+a[j];
        }
        cout<<sum;
        if(M==i)
        break;
        cout<<endl<<endl;
    }
    return 0;
}

题意的考察点在最后一个数据输出之后不会有题意换行,但有格式换行,但是Presentation Error的代码将数据输出的格式换行和题意换行绑定在一起,导致最后一个输出没有了格式换行

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值