Text Reverse

Text Reverse
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45977 Accepted Submission(s): 17625

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.
解题思路:这题如果想代码简单,要对getchar putchar函数的作用比较熟悉
AC代码如下:

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int main(){
	int n,f,k;
	char s[1008];
	cin>>n;
	getchar();
	while(n--){
		gets(s);    //读取字符串,以回车键结束
		f=strlen(s);               //判断字符串的长度
		for(int  i=0;i<=f;i++){
			if(s[i]==' '||i==f){     //碰到单词分隔的标志
				for( int j=i-1;j!=k&&j>=0;j--)
					putchar(s[j]);          //反向输出单词
				k=i;
				if(i!=f)
					putchar(' ');
			}
		}
		cout<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值