PAT甲级1124 Raffle for Weibo Followers (20 分)

1124 Raffle for Weibo Followers (20 )

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

      题目大意:

给定长度为m的转发名单,以及每n个人就中奖还有从第k个人开始。如果没有中奖用户,那么就输出Keep going…,因为同一个人可能会转发多次,如果这个人已经中奖了,那么就让下一个人中奖。

思路:

         由于转发名单是字符串,那么就用vector<string> 来装,然后是之前提到过,要把某类东西标志出来,而且是字符串那么就用map<string, bool> win,如果已经中奖过了,那么就让下标一直遍历到第一个没有中奖的人那里。然后由于是按照抽奖顺序输出的,那就每抽一个人输出一个就行咯。

 

参考代码:

 

 

#include<vector>
#include<string>
#include<map>
#include<iostream>
using namespace std;
vector<string> list;
map<string, bool> win;
int n, m, k;
int main(){
	scanf("%d%d%d", &m, &n, &k);
	list.resize(m + 1);
	for(int i = 1; i <= m; ++i)	cin >> list[i];
	bool ispt = false;
	for(int i = k; i <= m; i += n)
		if(!win[list[i]]){
			win[list[i]] = true;
			ispt = true;
			printf("%s\n", list[i].c_str());
		} else{
			while(i <= m && win[list[i]]) i++;
			if(i <= m && !win[list[i]]){
				printf("%s\n", list[i].c_str());
				win[list[i]] = true;
				ispt = true;
			}
		}
	if(!ispt)	printf("Keep going...");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值