1124 Raffle for Weibo Followers (20 分)

1124 Raffle for Weibo Followers (20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

note:m代表下面输入的行数,每行代表一个期盼中奖的名字,n代表从第一个中奖者到下一个中奖者的间隔数,s代表第一个中奖者的位置。在判断的过程中,如果当前人已经在前面中过奖了,则判断他的下一个人(每个人的名字可以多次出现,但是只能中奖一次)

#include<iostream>
#include<string>
#include<vector>
#include<unordered_map>
using namespace std;
int main(){
	int m,n,s;
	cin >> m >> n >> s;
	vector<string> v;
	unordered_map<string,int> book;
	v.push_back("nihao");
	for(int i = 0;i < m;i++){
		string str;
		cin >> str;
		v.push_back(str);
		book[str] = 0;
	}
	int flag = 0;
	for(int i = 1;i <= m;i++){
		//cout << v[i] << " " << book[v[i]] << endl;
		if(s == i && book[v[i]]==0){
			cout <<  v[i] << endl;
			flag=1;
			book[v[i]]=1;
			s+=n;
		}else if(s == i && book[v[i]]==1){
			s+=1;
		}
	}
	if(flag==0){
		cout << "Keep going..." << endl;
	}
	return 0;
	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值