PAT甲级1125 Chain the Ropes (25 分)

1125 Chain the Ropes (25 )

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

 

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2N104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

      题目大意:

     给出n段绳子长度,要求结成一条绳子后最长的长度,取整。

思路:

         容易想到哈夫曼树。在此简单证明思路的正确性。

         假设有绳子 a, b, c, d。且长度有 a < b < c < d,那么每次都选用最短的那两条编在一起,会有(a + b) / 2 = t1,(t1 + c) / 2 = t2, (t2 + d) / 2 = t3,这一定是最长的长度,因为t3 = a / 8 + b / 8 + c / 4 + d / 2,确保了最长的那条绳子损失的长度最小。可以随意更换 a 、 b 、 c 、d 的位置,但一定小于此时的t3。

         因为哈夫曼树会产生n – 1 个新结点,由此可知,最短的那两条,一定是除以 2 ^(n – 1), 依次递减直到除以2。(如果此处我没讲清楚的话,那就认为是上一段的推论)

         本来哈夫曼树是应该用set比较方便的,但是呢,例子已经提醒了,有可能有相同的数呢。乖乖用vector, 然后采用上述公式即可。千万不要用vector去模拟set,会超时的(那么即便set也可以用,set也会超时)

参考代码:

 

 

#include<cstdio>
#include<vector>
#include<algorithm>
#include<cmath>
using namespace std;
int n;
vector<double> list; 
double sum;
int main(){
	scanf("%d", &n);
	list.resize(n);
	for(int i = 0; i < n; ++i) scanf("%lf", &list[i]);
	sort(list.begin(), list.end());
	for(int i = 0; i < n; ++i){
		if(i == 0)	sum += list[i] / pow(2, n - 1);
		else sum += list[i] / pow(2, n - i);
	}
	printf("%d",(int)sum);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值