PAT甲级1128 N Queens Puzzle (20 分)

1128 N Queens Puzzle (20 )

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1,Q2,,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg9q.jpg  

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4N1000 and it is guaranteed that 1QiN for all i=1,,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

      题目大意:

     N皇后问题,所有皇后不能在同一行,同一列,同一对角线。已经假设了任一一对皇后都不在同一列上,那么给出k个分别为Ni长的序列,元素代表第i列的皇后在第i行。判断是否为解决办法。

思路:

          已经保证了列不同,接下来只要保证行不同与对角线不同即可。

          用一个exist作为标识该行是否已经有元素了,同行了让flag = false,录入完后如果flag == false 那么直接判断为NO,否则再进行对角线的判断。对角线判断要求任一两个元素其行差与列差不能相等。

参考代码:

 

 

 

#include<vector>
#include<algorithm>
#include<cstdio>
using namespace std;
vector<int>  list, exist;
int k, n;
int main(){
	scanf("%d", &k);
	for(int i = 0; i < k; ++i){
		scanf("%d", &n);
		exist.resize(n + 1);list.resize(n);
		exist.clear();
		bool flag = true;
		for(int j = 0; j < n; ++j){
			scanf("%d", &list[j]);
			if(!exist[list[j]]) exist[list[j]] = 1;
			else flag = false;
		}
		for(int j = 0; j < n; ++j)
			for(int z = j + 1; z < n; ++z)
				if(z - j == abs(list[j] - list[z])){
					flag = false;
					break;
				}
		if(!flag)	printf("NO\n");
		else  printf("YES\n");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值