PAT甲级1128 N Queens Puzzle

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)
Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1​​ ,Q2​​ ,⋯,QN​​ ), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.
Figure1
Figure2
Input Specification:
Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format " N Q1​​ Q2​​ … QN​​ ", where 4 ≤ N ≤ 1000 and it is guaranteed that 1≤ Qi​​ ≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
bool judge(vector<int>&);
int main()
{
	int K;
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		int N;
		cin >> N;
		vector<int> queen;
		for (int j = 0; j < N; j++)
		{
			int num;
			cin >> num;
			queen.push_back(num);
		}
		if (judge(queen))
			cout << "YES" << endl;
		else
			cout << "NO" << endl;
	}
	system("pause");
	return 0;
}
bool judge(vector<int> &vec)
{
	for (int i = 0; i < vec.size(); i++)
	{
		int ic = i + 1, ir = vec[i];
		for (int j = 0; j < vec.size(); j++)
		{
			if (j == i)
				continue;
			int jc = j + 1, jr = vec[j];
			if (jc == ic || jr == ir || abs(jc - ic) == abs(jr - ir))
				return false;
		}
	}
	return true;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值