PAT甲级1136 A Delayed Palindrome (20 分)

1136 A Delayed Palindrome (20 )

Consider a positive integer N written in standard notation with k+1 digits ai as aka1a0 with 0ai<10 for all i and ak>0. Then N is palindromic if and only if ai=aki for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

      题目大意:

        给定位数不超过1000位的正整数,如果他不是回文则将其反转相加,直到为回文为止。如果十次都无法形成回文那么就输出Not found in 10 iterations.

 

思路:

        由于要处理和反转,用string,且采用大整数型的进位算法,接着计步就可以了。
        注:如果是测试点4没有通过,问题在一开始就给出的是回文串,需要特判。
        如果是测试点2、 3 没有同,问题在如果是一位数时候,需要特判。
        此题如果升级,那么就要考虑先导零的情况了。

参考代码:

 

 

 

 

#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
string s1, s2;
void add(string &s1, string &s2){
	int carry = 0;
	for(int i = s1.size() - 1; i >=  0; --i){
		int temp = carry + stoi(s1.substr(i, 1)) + stoi(s2.substr(i, 1));
		s1[i] = '0' + temp % 10;
		carry = temp / 10; 
	}
	if(carry) s1.insert(s1.begin(), carry + '0');
}
bool judge(string &s){
	string temp = s;
	reverse(temp.begin(), temp.end());
	if(temp == s) return true;
	return false;
}
int main(){
	cin >> s1;
	if(s1.size() == 1){
		printf("%s is a palindromic number.", s1.c_str());
		return 0;
	}
	if(judge(s1)){
		printf("%s is a palindromic number.", s1.c_str());
		return 0;
	}
	int cnt = 0;
	while(cnt < 10){
		s2 = s1;
		reverse(s2.begin(), s2.end());
		printf("%s + %s = ", s1.c_str(), s2.c_str()); 
		add(s1, s2);
		printf("%s\n", s1.c_str());
		if(judge(s1)){
			printf("%s is a palindromic number.", s1.c_str());
			return 0;
		} 
		cnt++;
	}
	printf("Not found in 10 iterations.");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值