PAT甲级1139 First Contact (30 分)

1139 First Contact (30 )

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

      题目大意:

        两人要互述好感需要有两个中间人,如果是性别不同的两人A和B的话,需要先把与A相同性别的中间人输出,再输出B相同性别的,否则要求都是同性的朋友。
        假定有n个人,且有m对关系,随后给定k次查询,给出两人的id,请问能有多少对中间人。

 

思路:

  1. 用f表示同性朋友,存储相应的同性朋友。由于0与-0的情况存在,用string存储,并且当size相同的时候才为同性朋友。
  2. 用e表示可达性,并且巧用unordered_map制造较小的二维数组,那么当f[a][i] 与 f[b][j] 可达时,就证明了a和b两人可以传达好感。
  3. 由于结果需要分别排序,那么就用结构体存储,修改cmp函数即可。

参考代码:

 

 

 

#include<unordered_map>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
unordered_map<int, bool> e;
struct node{
	int a, b;
};
vector<vector<int> > f(10000);
bool cmp(node a, node b){
	return a.a != b.a ? a.a < b.a : a.b < b.b;
}
int n, m, k;
int main(){
	scanf("%d%d", &n, &m);
	for(int i = 0; i < m; ++i){
		string a, b;
		cin >> a >> b;
		if(a.size() == b.size()){
			f[abs(stoi(a))].push_back(abs(stoi(b)));
			f[abs(stoi(b))].push_back(abs(stoi(a)));
		}
		e[abs(stoi(a)) * 10000 + abs(stoi(b))] = e[abs(stoi(b))* 10000 + abs(stoi(a))] = true;
	}
	scanf("%d", &k);
	for(int i = 0; i < k; ++i){
		int a, b;
		scanf("%d%d", &a, &b);
		vector<node> ans;
		for(int t = 0; t < f[abs(a)].size(); ++t)
			for(int j = 0; j < f[abs(b)].size(); ++j){
				if(f[abs(a)][t] == abs(b) || f[abs(b)][j] == abs(a)) continue;
				if(e[f[abs(a)][t] * 10000 + f[abs(b)][j] ])
					ans.push_back({f[abs(a)][t], f[abs(b)][j]}); 
			}
		sort(ans.begin(), ans.end(), cmp);
		printf("%d\n", ans.size());
		for(int j = 0; j < ans.size(); ++j)
			printf("%04d %04d\n", ans[j].a, ans[j].b);
	}
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/79065004

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值