PAT甲级1142 Maximal Clique (25 分)

1142 Maximal Clique (25 )

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

      题目大意:

        给出n个结点和m条边,确定给出的k个点集是否为完全图的点集。

 

思路:

  1. 用邻接矩阵存储图,先判断是否为clique。判断方法为依次枚举,查看两两是否都相连着。
  2. 判断是否为最大的clique:选择序列外的一点,只有该点与序列任一一点都有路径的时候才不为最大的clique。

参考代码:

 

 

 

#include<vector>
#include<algorithm>
#include<cstdio>
using namespace std;
bool g[201][201];
int n, m, k, p;
int  main(){
	scanf("%d%d", &n, &m);
	for(int i = 0; i < m; ++i){
		int a, b;
		scanf("%d%d", &a, &b);
		g[a][b] = g[b][a] = true;
	}
	scanf("%d", &p);
	for(int i = 0 ; i < p; ++i){
		scanf("%d", &k);
		vector<int> t(k);
		for(int j = 0; j < k; ++j)	scanf("%d", &t[j]);
		bool isc = true;
		for(int j = 0; j < k; ++j)
			if(!isc) break;
			else
			for(int z = j + 1; z < k; ++z)
				if(!g[t[j]][t[z]]){
					isc = false;
					break;
				}
		if(!isc){
			printf("Not a Clique\n");
			continue;
		}
		bool ismax = true;
		sort(t.begin(), t.end());
		vector<bool> exist(n + 1);
		for(int j = 0; j < k; ++j) exist[t[j]] = true;	
		for(int j = 1; j <= n; ++j){
			if(!ismax) break;
			if(!exist[j]){
			for(int z = 0; z < k; ++z)
				if(!g[t[z]][j]) break;
				else if(z == k - 1) ismax = false;
			}
		}
		if(ismax) printf("Yes\n");
		else printf("Not Maximal\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值