PAT甲级-1142-Maximal Clique(最大连通分量)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique(graph_theory))
Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

思路:
1.先判断是否是连通分量

如果顶点中有一对不可达,那它就是不是连通分量。
注意:break跳出里层循环后,在外层循环还要再设一个判断让它再跳一次!

2.再判断是否是最大连通分量

如果剩余顶点中有一个顶点的加入使得该图连通了(x是剩余顶点中的一个【一个即可】,y是当前连通分量中的顶点,所有graph[x][y]都为1),那它就不是最大连通分量。
注意:break跳出里层循环后,就可以不用管了!因为里层循环如果能走完,就说明连通了,即不是最大连通分量!

代码如下

#include<iostream>
#include<vector>
const int N = 205;
using namespace std;
int graph[N][N],visit[N];
int main()
{
	int nv,e,m,k,x,y;
	cin>>nv>>e;
	fill(graph[0],graph[0]+N*N,0);
	while(e--){
		cin>>x>>y;
		graph[x][y] = graph[y][x] = 1;
	}
	cin>>m;
	while(m--){
		int isClique = 1,isMaximum = 1;
		fill(visit,visit+N,0);
		cin>>k;vector<int> v(k);
		for(int i = 0; i < k; i++){
			cin>>v[i];
			visit[v[i]] = 1;
		}
		for(int i = 0; i < k; i++){//1.先判断是否是连通分量 
			for(int j = i+1; j < k; j++){
				if(isClique == 0) break;
				if(graph[v[i]][v[j]] == 0){
					isClique = 0;
					cout<<"Not a Clique"<<endl;
					break;
				}
			} 
		}
		if(isClique == 0) continue;
		for(int i = 1; i <= nv; i++){//2.再判断是否是最大连通分量
			if(!visit[i]){
				for(int j = 0; j < k; j++){
					if(graph[i][v[j]] == 0) break;
					if(j == k-1){isMaximum = 0;}
				}
			}
			if(isMaximum == 0){
				cout<<"Not Maximal"<<endl;break;
			}
		}
		if(isMaximum == 1) cout<<"Yes"<<endl;
	}
	return 0;
}
  • 7
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值