PAT甲级1146 Topological Order (25 分)

1146 Topological Order (25 )

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

 

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

   题目大意:

        给出n个结点和m条边的图,随后有k个序列,查找非拓扑排序序列的那个序列,输出序列下标,下标从0 ~ k - 1
 

 

思路:

  1. 用邻接表存储图,用cnt记录每个结点的入度。
  2. 读入k个序列,查看当前结点的入度是否为0,如果不是就肯定不是拓扑排序。如果是则访问邻接表,把其相应的出度点都减1。

参考代码:

 

 

 

#include<vector>
#include<cstdio>
using namespace std;
vector<int> cnt, tcnt;
vector<vector<int> > e;
int n, m, k;
int main(){
	scanf("%d%d", &n, &m);
	e.resize(n + 1); cnt.resize(n + 1);
	for(int i = 0; i < m; ++i){
		int a, b;
		scanf("%d%d", &a, &b);
		e[a].push_back(b);
		cnt[b]++;
	}
	scanf("%d", &k);
	bool ispt = false;
	for(int i = 0; i < k; ++i){
		tcnt = cnt;
		bool flag = true;
		for(int j = 0; j < n; ++j){
			int temp;
			scanf("%d", &temp);
			if(tcnt[temp])	flag = false;
			for(int z = 0; z < e[temp].size(); ++z)
				tcnt[e[temp][z]]--;
		}
		if(!flag)
			if(!ispt)	printf("%d", i), ispt = true;
			else printf(" %d", i);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值