1146 Topological Order(25 分)

1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目大意:给一个有向图,判断给定序列是否是拓扑序列~

#include <iostream>
#include <vector>
using namespace std;

const int MAX = 1010;

vector<int> v[MAX], res;
int inD[MAX];
int tmpD[MAX];
void copyD(){
    for(int i = 0; i < MAX; i++) {
        tmpD[i] = inD[i];
    }
}
bool topSort(vector<int> &vec){
    for(int i = 0; i < vec.size(); i++){
        int u = vec[i];
        if(tmpD[u] == 0){
            for(int j = 0; j < v[u].size(); j++){
                int t = v[u][j];
                tmpD[t]--;
            }
        }
        else return false;
    }
    return true;
}
int main() {
    int n, m;
    vector<int> ans;
    cin >> n >> m;
    int a, b;
    for(int i = 0; i < m; i++){
        cin >> a >> b;
        v[a].push_back(b);
        inD[b]++;
    }
    int k;
    cin >> k;
    for(int i = 0; i < k; i++){
        copyD();
        int u;
        for(int j = 0; j < n; j++){
            cin >> u;
            res.push_back(u);
        }
        if(!topSort(res))   ans.push_back(i);
        res.clear();
    }
    for(int i = 0; i < ans.size(); i++){
        if(i == 0) cout << ans[i];
        else cout << " " << ans[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值