PAT甲级1019 General Palindromic Number (20 分)

1019 General Palindromic Number (20 )

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits ai as ∑i=0k(aibi). Here, as usual, 0ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai=aki for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N109 is the decimal number and 2b109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak ak1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题目大意:

         给定一个数n与基b,问n在基b的情况下是否为回文串。输出Yes(No)并在下一行输出相应进制的结果。

 

思路:

         利用reverse函数,第一段是将n转化为b进制的(此时存储的是相反的结果,如sample2,此时存储的144,相当于获得了一个倒置的结果)。然后将其赋值给另一个vector变量,reverse走一趟,reverse出来是输出结果。判断两个变量是否相等即可。

参考代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int n, b;
int main(){
	scanf("%d%d", &n, &b);
	vector<int> num1, num2;
	do{
		num1.push_back(n % b);
		n /= b;
	}while(n);
	num2 = num1;
	reverse(num1.begin(), num1.end());
	if(num1 == num2)	printf("Yes\n");
	else	printf("No\n");
	printf("%d", num1[0]);
	for(int i = 1; i < num1.size(); ++i)
		printf(" %d", num1[i]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值