PAT甲级1046 Shortest Distance (20 分)

1046 Shortest Distance (20 )

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题目大意:

         给出n条路径长度,每条路径长度是第i个结点通往第i+ 1个结点的路径长度, 即会形成一个环,要求给出m个起点和终点求得最短距离。

 

思路:

     Dis数组存储从1号结点到下标+1号结点的距离,如dis【1】存储的是1 到2号结点的距离。每次给出的询问,将起始于结束结点的位置调整好,输出min(dis[ed – 1] – dis[st – 1], dis[n] – dis[ed – 1] + dis[st – 1]),即顺时针的路径长度(从编号小的到编号大的如1 –> 3)与其逆时针长度(逆着走)的最小值。

    

参考代码:

#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
int n, m;
vector<int> dis;
int main(){
	scanf("%d", &n);
	dis.resize(n + 1);
	for(int i = 1; i <= n; ++i){
		scanf("%d", &dis[i]);
		dis[i] += dis[i - 1];
	}
	scanf("%d", &m);
	for(int i = 0; i < m; ++i){
		int st, ed;
		scanf("%d%d", &st, &ed);
		if(st > ed)	swap(st, ed);
		int temp = dis[ed - 1] - dis[st - 1];
		printf("%d\n", min(temp, dis[n] - temp));
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值