【PAT(甲级)】1046 Shortest Distance(距离分析)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1​ D2​ ⋯ DN​, where Di​ is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

解题思路:

像这种从一个点到另一个点连续给出路程的题目,节约时间都是用sum把距离加起来的。读取数据的时候就是直接把距离加起来,然后求两点距离就是目的位置减去初始位置。

但是这题稍微复杂一点,他的路径是一个,所以还可以逆方向走一遍,要求找出最短的路。

所以如上图所示,如果是点1到点4的距离,就应该是7,或者30-7;点2到点5的距离就应该是21,或者31-21。也就是说,假设其实点位start,末点为end,顺时针的距离就是 dis[end-1]-dis[start-1];

逆时针的距离就是dis[N]+dis[start-1]-dis[end-1]。因为存储问题,下标的话也许会不同。

代码:

#include<bits/stdc++.h>
using namespace std;
int N;
int dis[99999999]={0};
int rdis[99999999]={0};

int main(){
	scanf("%d",&N);
	for(int i=1;i<=N;i++){
		int n;
		scanf("%d",&n);
		dis[i] = n+dis[i-1];
	}
	int M;
	scanf("%d",&M);
	for(int i=0;i<M;i++){
		int start,end;
		scanf("%d%d",&start,&end);
		if(end<start){
			int temp;
			temp = end;
			end = start;
			start = temp;
		}
		int min_d;
		min_d = dis[end-1]-dis[start-1];//顺时针的距离 
		
		printf("%d\n",min(min_d,dis[N]+dis[start-1]-dis[end-1]));//比较顺时针与逆时针的距离谁小 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值