PAT甲级1069 The Black Hole of Numbers (20 分)

1069 The Black Hole of Numbers (20 )

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

      题目大意:

         给出任意4位不相等的数,将其从大到小得出的数减去从小到大得出的数如果等于6174时即停止运算。如果4位相等时运行一步即停止。

 

思路:

         因为要排序故选用string存储,注意可能给出的数不足4位如0,123,要补足成4位。在前面添加0。还要注意的是如果一开始就给出6174也要运行一遍后才能停止。

 

参考代码:

 

#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
string s1, s2;
int main(){
	cin >> s1;
	s1.insert(0, 4 - s1.size(), '0');
	do{
		sort(s1.begin(), s1.end());
		s2 = s1;
		reverse(s1.begin(), s1.end());
		int temp1 = stoi(s1), temp2 = stoi(s2);
		printf("%04d - %04d = %04d\n", temp1, temp2, temp1 - temp2);
		s1 = to_string(temp1 - temp2);
		s1.insert(0, 4 - s1.size(), '0');
	}while(s1 != "6174" && s1 != "0000");
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/52497341

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值