PTA题目A1069 The Black Hole of Numbers

对于任何4位数(数字不全相同),通过排序数字并取差值,最终会进入6174这个数字黑洞。例如,从6767开始,经过几次计算后将得到6174,这个过程被称为Kaprekar常数现象。程序需要展示任意4位数如何到达这个黑洞。
摘要由CSDN通过智能技术生成

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10^​4).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

// 数字黑洞,这里注意输出格式,前面补零用%04d
//
#include <iostream>
#include<cstdio>
#include <string>
#include<vector>
#include<algorithm>


void to_array(int num, int array[]) {//数字转换成数组
	for (int i = 0; i < 4; i++) {
		array[3 - i] = num % 10;
		num /= 10;
	}
}
int to_number(int array[]) {
	int temp = 0;
	for (int i = 0; i < 4; i++)
		temp = temp * 10 + array[i];
	return temp;
}

bool cmp(int a, int b) {//递减排序
	return a > b;
}
int main() {
	int num, array[4];
	int a1, a2;		//递增递减排序后的两个数
	std::cin >> num;

	while (1) {
		to_array(num, array);
		std::sort(array, array + 4);
		a1 = to_number(array);
		std::sort(array, array + 4, cmp);
		a2 = to_number(array);
		num = a2 - a1;
		printf("%04d - %04d = %04d\n", a2, a1, a2 - a1);//高位记得补零
		if (num == 6174 || num == 0)
			break;
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值