PAT甲级1093 Count PAT's (25 分)

1093 Count PAT's (25 )

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

      题目大意:

         给定一个字符串,请问从左向右的元素中可以组成多少个PAT?结果mod1000000007

 

 

思路:

         用String存储。算法思想如下:对于每一个A,其左边的P个数与右边T个数的乘积即为其能构成的PAT个数。

         那么就先将所有的t个数都记录下来,然后从头开始遍历,遇到P则cp++, 遇到t则ct++(因为是在准备要找的A的前面), 遇到A就开始计数了。

         由于要mod1000000007 所以算是变相提示了应当用int来计数并且每次加减乘除的时候应当都mod一次。

 

参考代码:

 

 

#include<string>
#include<iostream>
using namespace std;
int  cp, ca, ct, ans;
int main(){
	string s;
	cin >> s;
	for(int i = 0; i < s.size(); ++i)
		if(s[i] == 'T')	ct++;
	for(int i = 0; i < s.size(); ++i){
		if(s[i] == 'P') cp++;
		if(s[i] == 'T') ct--;
		if(s[i] == 'A') ans = (ans + (cp * ct) % 1000000007) % 1000000007;
	}
	printf("%d", ans);
	return 0;
} 

代码参考:https://blog.csdn.net/liuchuo/article/details/51985909

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值