1093 Count PAT's (25)(25 分)

1093 Count PAT's (25)(25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10^5^ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

嗯是道思维题,只要统计出来A前面有多少个P  和A后面有多少个T 让他们相乘就可以了

代码

#include<bits/stdc++.h>
using namespace std;
const int mod = 1000000007;
const int maxn=1e5+10;
int l[maxn];
int r[maxn];
int main()
{
	string s;
	cin>>s;
	int len = s.length();
	int cnt = 0;
	for(int i = 0;i < len;i++) 
	{
		if(s[i]=='P')
			cnt++;
		else if(s[i] == 'A')
			l[i] = cnt;
	}
	cnt = 0;
	for(int i = len-1; i >= 0; i--)
	{
		if(s[i] == 'T')
			cnt++;
		else if(s[i] == 'A')
			r[i] = cnt;
	}
	int sum = 0;
	for(int i = 0 ;i <len;i++)
	{
		if(l[i]!=0)
			sum = (sum + (l[i] * r[i]) % mod) %mod;
	}
	printf("%d\n",sum);
	return 0;
}
    

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值