PAT甲级1098 Insertion or Heap Sort (25 分)

1098 Insertion or Heap Sort (25 )

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

 

      题目大意:

         给定长度为n的序列,随后给出初始序列与某一状态的序列,请问是插入排序还是堆排序(大顶堆)。

 

 

思路:

         插入排序的特点是找到第一个s1[i] > s1[I + 1],且让j 从 i开始看下剩余的序列是否没动过。如果是那么就是插入排序,否则就是堆排序。堆排序模拟就好了。

    对于堆排序而言,从后往前找到第一个小于等于b[0]的元素,然后交换,记得在downadjust一次。

 

参考代码:

 

 

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> a, b;
int n, i, j;
void downadj(int low, int high){
	int i = low, j = i * 2 + 1;
	while(j <= high){
		if(j + 1 <= high && b[j + 1] > b[j]) j = j + 1;
		if(b[j] <= b[i]) break;
		swap(b[j], b[i]);
		i = j; j = i * 2 + 1;
	}
}
int main(){
	scanf("%d", &n);
	a.resize(n), b.resize(n);
	for(i = 0; i < n; ++i)	scanf("%d", &a[i]);
	for(i = 0; i < n; ++i)	scanf("%d", &b[i]);
	for(i = 1; i < n && b[i ] >=  b[i - 1]; ++i);
	for(j = i; j < n && a[j] == b[j]; ++j);
	if(j == n)	sort(b.begin(), b.begin() + i + 1), printf("Insertion Sort\n");
	else{
		printf("Heap Sort\n");
		j = n - 1;
		while(j > 0 && b[j] >= b[0]) j--;
		swap(b[0], b[j]);
		downadj(0, j - 1);
	}
	printf("%d", b[0]);
	for(i = 1; i < n; ++i)	printf(" %d", b[i]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值