PAT甲级——A1098 Insertion or Heap Sort【25】

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

Solution:

    脑中有十大排序算法原理的思维,这道题就不难做了。

    首先最简单的就是判断是不是插入排序了,由于插入排序是从前向后的,所以后面未排序的数组数值应该与原数组保持一致的,否则就是堆排序算法。

   如果是堆算法,那么我们就按照堆排序算法进行,一旦发现排序中的某一步与sorted数组一样,那么再进行一步堆排序算法就可以输出了


#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
void downAdjust(vector<int>&v, int L, int R)
{
	int i = L, j = 2 * L + 1;//i父节点,j左孩子
	while (j <= R)
	{
		if (j + 1 <= R && v[j + 1] > v[j])++j;//找到最大的左右孩子
		if (v[i] >= v[j])break;//父节点最大,无需调整
		swap(v[j], v[i]);//否则就交换父节点与子节点
		i = j;
		j = 2 * i + 1;
	}
}
int main()
{
	int n;
	cin >> n;
	vector<int>initial(n), sorted(n);
	for (int i = 0; i < n; ++i)
		cin >> initial[i];
	for (int i = 0; i < n; ++i)
		cin >> sorted[i];
	int k = 1;
	while (k < n && sorted[k - 1] <= sorted[k])++k;//找到未排序的位置
	bool isInsert = true;
	for (int i = k; i < n && isInsert; ++i)//判断未排序的部分是不是与原数组一样
		if (initial[i] != sorted[i])
			isInsert = false;//不一样就不是插入排序
	if (isInsert)
	{
		printf("Insertion Sort\n");
		sort(sorted.begin(), sorted.begin() + k + 1);//再进行一步
	}
	else
	{
		printf("Heap Sort\n");
		for (int i = n / 2; i >= 0; --i)
			downAdjust(initial, i, n - 1);
		bool over = false;
		for (int i = n - 1; i > 0; --i)//一定把v[0]留住
		{
			swap(initial[0], initial[i]);//交换
			downAdjust(initial, 0, i - 1);//调整
			if (over)break;//排序结束
			if (initial == sorted)over = true;//使用标志,再排一次序就立马结束
		}
		sorted = initial;
	}
	for (int i = 0; i < n; ++i)
		cout << (i == 0 ? "" : " ") << sorted[i];
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值