PAT甲级1105 Spiral Matrix (25 分)

1105 Spiral Matrix (25 )

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to Nmn; and mn is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

 

      题目大意:

         给出长度为n的数字序列,非升序的,顺时针方向填入数列。形成一个m x n 的矩阵,要求m >= n, min{m – n}.

 

 

思路:

         n从sqrtN到 1,(此时m一定会大于等于n) 只要能被整除就让m = N / n.不妨如此思考,每输出一圈为一次输出,那么共有m / 2 + m % 2. 因为一圈都消耗了(减少了)上下两行, 如果为计数的时候应当能表示出来.每次一层都控制则打印的宽度与高度.

 

参考代码:

 

#include<cstdio>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;
bool cmp(int a, int b){return a > b;}
int n, m, N;
int main(){
	scanf("%d", &N);
	vector<int> a(N);
	for(n = sqrt((double) N); n >= 1; --n)
		if(N % n == 0){
			m = N / n;
			break;
		}
	for(int i = 0; i < N; ++i)	scanf("%d", &a[i]);
	sort(a.begin(), a.end(), cmp);
	vector<vector<int> > b(m, vector<int> (n)); 
	int layer = m / 2 + m % 2, idx = 0;
	for(int i = 0; i < layer; ++i){
		for(int j = i; j < n - i && idx < N; ++j)
			b[i][j] = a[idx++];
		for(int j = i + 1; j < m - 1 - i && idx < N; ++j)
			b[j][n - 1 - i] = a[idx++];
		for(int j = n - 1 - i; j >= i && idx < N; --j)
			b[m - 1 - i][j] = a[idx++];
		for(int j = m - 2 - i; j > i && idx < N; --j)
			b[j][i] = a[idx++];
	}
	for(int i = 0; i < m; ++i)
		for(int j = 0; j < n; ++j)
			printf("%d%c", b[i][j], j != n - 1? ' ': '\n');
	return 0;
}

 

代码参考:https://blog.csdn.net/liuchuo/article/details/52123228

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值