【PAT】1105. Spiral Matrix (25)【模拟】

题目描述

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

翻译:这一次你的任务是将一个包含N个正整数的数列按照降序排序塞入一个螺旋矩阵中去。从左上角的第一个元素填充一个螺旋矩阵,然后顺时针旋转。矩阵有m行和n列,m和n满足以下几点:m×n必须等于n;m≥n;n和m是所有可能的值中的最小值。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括给定一个正整数N。接下来一行包含N个正整数来填充螺旋矩阵。所有数字都不大于104。一行内的数字之间用空格隔开。

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

翻译:对于每组输入数据,输出m行结果矩阵,每行包括n个数字。每两个相邻数字之间必须有1个空格,并且每行末尾不能有多余空格。


Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93


Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76


解题思路

模拟题目要求即可。我的代码里的m和n是反的,n行m列。。。注意停止条件判断,否则会出现段错误。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int N,m,n;
int v[10010];
int fun(){
	int sq=(int)sqrt(N);
	for(int i=sq;i<=N;i++){
		if(N%i==0){
			if(N/i>i)i=N/i;
			return i;
		}
	}
}
bool cmp(int a,int b){
	return a>b;
}
int main(){
	scanf("%d",&N);
	for(int i=0;i<N;i++)scanf("%d",&v[i]); 
	sort(v,v+N,cmp);
	n=fun();
	m=N/n;
	int ans[n][m],ccount=0;
	for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
			ans[i][j]=0;
	for(int k=0;k<m;k++){
		for(int j=k;j<=m-1-k;j++){
			if(ccount<N)ans[k][j]=v[ccount++];
			else break;
		}		
		for(int i=k+1;i<=n-1-k;i++){
			if(ccount<N)ans[i][m-1-k]=v[ccount++];
			else break;		
		}
		for(int j=m-2-k;j>=k;j--){
			if(ccount<N)ans[n-1-k][j]=v[ccount++];
			else break;	
		}
		for(int i=n-2-k;i>k;i--){
			if(ccount<N)ans[i][k]=v[ccount++];
			else break;	
		} 
	}
	for(int i=0;i<n;i++){
		for(int j=0;j<m-1;j++)
			printf("%d ",ans[i][j]);
		printf("%d\n",ans[i][m-1]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值