PAT甲级1052 Linked List Sorting

1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10^​5​​ ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:
Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题意:将链表按照链表中的data从小到大排序

思路:用静态链表做。结点中定义add,data,next,flag;flag用于标记此结点是否为有效结点。一开始将所有结点的flag初始化为false,初始化所有结点的所有变量后再从头遍历结点将遍历地到的结点的flag赋值为true,然后用sort函数进行二级排序,最后输出。

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct Node {
	int add,next,data;
	bool flag=false;                 //初始化为false
}node[100010];
bool cmp(Node a, Node b) {           
    //结构体二级排序,若有结点不是有效结点,则将有效结点放在左边,否则按照data从小到大排序
	if (!a.flag || !b.flag) return a.flag > b.flag;
	else return a.data < b.data;
}
int main()
{
	int head, N, count=0,p,i,d, a, n;
	scanf("%d%d", &N, &head);
	while(N){                                      //初始化
		scanf("%d", &a);
        scanf("%d%d",&node[a].data,&node[a].next);
		node[a].add = a;
		N--;
	}
	p = head;
	while (p != -1) {                      //遍历链表将所有结点的flag设置为true
		node[p].flag = true;
		count++;                           //结点计数器
		p = node[p].next;
	}
	sort(node, node + 100010,cmp);
    if(!count) printf("0 -1");                 //注意考虑没有有效结点的情况,否则最后一个测试点无法通过
	else{ 
        printf("%d %05d\n", count, node[0].add);     
	    for ( i = 0; i < count - 1; i++)
		    printf("%05d %d %05d\n", node[i].add, node[i].data, node[i + 1].add);
	    printf("%05d %d -1\n", node[i].add, node[i].data);
        }
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值