PAT甲级 1032 Sharing

**

1032 Sharing (25 分)

**
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1

题意:找到两个单词共同后缀的初始地址

由于数量较小(<=10^5),所以可以直接使用静态链表做。

思路:
1.设置结构体数组,结点中定义三个变量count,next和c,count作为标记使用,next为该结点指针指向的下一个地址,c表示该结点代表的字母,下标作为该结点自己的地址;

2.将count定义为0,初始化后遍历任意一个字母链表将count赋值为1,而后再遍历另一个字母链表碰到count=1的结点就代表该结点为共同后缀的第一个字母;
(一开始我的思路是结点中放的int类型的count用来进行对指向该结点的指针进行计数,最后遍历任何一个单词,发现count=2的字母结点就表示该字母结点为共同后缀的第一个字符,但是有两个测试点始终过不了)

ac代码:

#include<stdio.h>
#include<stdlib.h>
struct Node {
	int next;
	char c;
	int count=0;
}node[100000];
int main()
{
	int N,s1,s2,head1,head2,i=0;
	char c;
	scanf("%d%d%d", &head1, &head2, &N);           //第一个结点
	while (N) {                                      //初始化
		scanf("%d %c ", &s1, &c);
		scanf("%d", &s2);
		node[s1].c = c;
		node[s1].next = s2;
		N--;
	}
    i=head2;
    while(i!=-1){
        node[i].count=1;
        i=node[i].next;
    }
	i = head1;
	while (i!=-1) {
		if (node[i].count == 1) {
			printf("%05d\n",i);
            return 0;
		}
		i = node[i].next;
	}
	printf("-1");
	return 0;
}

初始代码:

#include<stdio.h>
#include<stdlib.h>
struct Node {
	int next;
	char c;
	int count;
}node[100000];
int main()
{
	int N,s1,s2,head1,head2,i=0;
	char c;
	scanf_s("%d%d%d", &head1, &head2, &N);           //第一个结点
	node[head1].count++;
	node[head2].count++;
	while (N) {                                      //初始化
		scanf_s("%d %c ", &s1, &c);
		scanf_s("%d", &s2);
		node[s1].c = c;
		node[s1].next = s2;
		node[s2].count++;
		N--;
	}
	i = head1;
	while (i != -1) {
		if (node[i].count == 2) {
			printf("%05d\n",i);
			break;
		}
		i = node[i].next;
	}
	if (i == -1)
		printf("-1");
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值